0
$\begingroup$

steps to reproduce the bug

  1. click "edit" on Can anyone identify this object?
  2. try adding 1 tag (as an edit suggestion)

result

error message: "edits must be at least 6 characters" (red rectangle around composition window)

suspected source of the bug

My hunch is that the bug occurs when questions have the or tags, because adding tags to all other questions works just fine, whereas theses tags trigger a yellow warning message.

  • When adding 1 tag as an edit suggestion for THIS QUESTION, I get the red rectangle ("at least 6 chars") around the composition box and the yellow warning text below the tags - related to the preexisting accident and accident-investigation tags.

  • For ALL OTHER QUESTIONS (without these tags) I can add 1 tag (and add zero characters to the question) as an edit suggestion without getting either one of these errors (i.e. no red red or yellow warning). I have done this many times. Therefore I suspect this to be the source of the bug.

$\endgroup$
  • $\begingroup$ Can this bug please be investigated? Because as can be seen from the discussion below Glorfindel's answer, I think this is a separate bug. (I couldn't find a zero-with character even using a hex-editor). $\endgroup$ – summerrain Dec 11 '18 at 9:37
4
$\begingroup$

I had a similar problem on another Stack Exchange and asked about it here.

There was a single zero-width space at the end of the post body. These are stripped on submission now... Unfortunately, that's done before the system compares the revisions to see what has changed. So it saw the tag edits and a one-character body edit.

As a sub-2k user, you can't make one-character body edits (unless you edit the title as well), that's why you get the error message. It will only happen on relatively old posts, irrespective of the tags.

The powers that be might have deemed it not important enough to fix this bug, since there are numerous workarounds:

  • find something else to fix in the post (e.g. a more specific title)
    • this fix by itself might be rejected as 'too minor', so be sure to specify in the edit summary that you're only doing this to avoid this very problem
  • find somebody with enough reputation to make the desired change (e.g. in chat)
$\endgroup$
  • $\begingroup$ thanks. you reported this bug more than 1 year ago. So it still hasn't been fixed ? $\endgroup$ – summerrain Dec 11 '18 at 8:57
  • 2
    $\begingroup$ I think 'they' have deemed it not important enough to fix, since there are numerous workarounds: find something else to fix in the post (e.g. a more specific title), find somebody with enough reputation to make the desired change (e.g. in chat)... $\endgroup$ – Glorfindel Dec 11 '18 at 8:59
  • $\begingroup$ Upon further investigation, I don' think this is the same bug. You say the bug is related to the age of the question, irrespective of tags. But this question is from August 2015 whereas I successfully tagged this question from March 2014. $\endgroup$ – summerrain Dec 11 '18 at 9:15
  • 1
    $\begingroup$ Well, that last question didn't have a zero-width space, then. $\endgroup$ – Glorfindel Dec 11 '18 at 9:16
  • $\begingroup$ re: "find something else to fix in the post" most of the time, there is nothing else to "fix" and it shouldn't be the requirement for adding a tag at any rate. (Case in point: do you see another useful edit in the question we are talking about? if it's not a substantial, useful edit, it will be rejected most of the time) $\endgroup$ – summerrain Dec 11 '18 at 9:19
  • $\begingroup$ Didn't you say the zero-width space "only happens on relatively old posts" ? How does that rhyme with a newer question suffering from this bug when an older question doesn't ? $\endgroup$ – summerrain Dec 11 '18 at 9:21
  • 1
    $\begingroup$ It doesn't happen all the time. Some old posts have zero-width spaces (or other stripped characters), some don't. You'll only experience this bug with posts that have them. $\endgroup$ – Glorfindel Dec 11 '18 at 9:22
  • $\begingroup$ I have pasted the body text into a hex editor. There is no zero-width space in this question. $\endgroup$ – summerrain Dec 11 '18 at 9:34
  • 1
    $\begingroup$ I'll ping Shog on the answer to my Meta question and see if he can comment here as well. $\endgroup$ – Glorfindel Dec 11 '18 at 9:35
  • $\begingroup$ thank you, that is very helpful! $\endgroup$ – summerrain Dec 11 '18 at 9:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .